1SUMMARY = "BIOS BMC SMM Error Logger"
2DESCRIPTION = "Allows BIOS in SMM to log errors to the BMC"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5DEPENDS += " \
6  boost \
7  stdplus \
8  systemd \
9  nlohmann-json \
10  libbej \
11  sdbusplus \
12  phosphor-dbus-interfaces \
13"
14SRCREV = "5de90619619115af21ffa5c7bae279e88bd86429"
15PV = "0.1+git${SRCPV}"
16PR = "r1"
17
18SRC_URI = "git://github.com/openbmc/bios-bmc-smm-error-logger;branch=main;protocol=https"
19
20S = "${WORKDIR}/git"
21SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.bios_bmc_smm_error_logger.service"
22
23inherit meson pkgconfig systemd
24
25EXTRA_OEMESON = " \
26  -Dtests=disabled \
27"
28