1SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit meson pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "sdbusplus"
13DEPENDS += "systemd"
14DEPENDS += "phosphor-dbus-interfaces"
15DEPENDS += "boost"
16
17DBUS_SERVICE:${PN} += "xyz.openbmc_project.led.controller@.service"
18
19EXTRA_OEMESON:append = " -Dtests=disabled"
20
21SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs;branch=master;protocol=https"
22SRC_URI += "file://70-leds.rules"
23SRCREV = "1f2b932bb9ef88d97a6313f4dc087fb1f2eb399a"
24S = "${WORKDIR}/git"
25
26do_install:append() {
27        install -d ${D}/${nonarch_base_libdir}/udev/rules.d/
28        install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${nonarch_base_libdir}/udev/rules.d/
29}
30