1SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14DEPENDS += "systemd"
15DEPENDS += "phosphor-dbus-interfaces"
16DEPENDS += "boost"
17
18DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service"
19
20SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs"
21SRC_URI += "file://70-leds.rules"
22SRCREV = "61b906367119b794a9788725fad86a3174bd83c0"
23S = "${WORKDIR}/git"
24
25do_install_append() {
26        install -d ${D}/${base_libdir}/udev/rules.d/
27        install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/
28}
29