1SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit meson pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "sdbusplus"
13DEPENDS += "systemd"
14DEPENDS += "phosphor-dbus-interfaces"
15DEPENDS += "boost"
16
17DBUS_SERVICE:${PN} += "xyz.openbmc_project.led.controller@.service"
18
19EXTRA_OEMESON += "-Dtests=disabled"
20
21SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs"
22SRC_URI += "file://70-leds.rules"
23SRCREV = "5ee5f3b7162cb5d8e6780a9571e0b0ca3daf7c6e"
24S = "${WORKDIR}/git"
25
26do_install:append() {
27        install -d ${D}/${base_libdir}/udev/rules.d/
28        install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/
29}
30