1SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
10inherit systemd
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "cli11"
14DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
17
18RRECOMMENDS_${PN} = "pam-ipmi"
19
20SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
21SRCREV = "7b645018775b85a0c61148e592d951841809eef9"
22
23S = "${WORKDIR}/git"
24
25FILES_${PN} += " \
26        ${systemd_system_unitdir}/${PN}@.service \
27        ${systemd_system_unitdir}/${PN}@.socket \
28        "
29
30# If RMCPP_IFACE is not set by bbappend, set it to default
31DEFAULT_RMCPP_IFACE = "eth0"
32RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
33
34# install parameterized service and socket files
35SYSTEMD_SERVICE_${PN} = " \
36        ${PN}@${RMCPP_IFACE}.service \
37        ${PN}@${RMCPP_IFACE}.socket \
38        "
39
40# To add another RMCPP interface, add similar lines to the
41# following lines in a bbappend:
42#
43# ALT_RMCPP_IFACE = "eth1"
44# SYSTEMD_SERVICE_${PN} += " \
45#     ${PN}@${ALT_RMCPP_IFACE}.service \
46#     ${PN}@${ALT_RMCPP_IFACE}.socket \
47#     "
48
49# Also, be sure to enable a corresponding entry in the channel
50# config file with the same 'name' as the interfaces above
51# Override the default phosphor-ipmi-config.bb with a bbappend
52
53