1SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
10inherit systemd
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "cli11"
14DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
17
18SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
19SRCREV = "5b114ed728fa1631bdbc1f85b1e3570821c6825e"
20
21S = "${WORKDIR}/git"
22
23FILES_${PN} += " \
24        ${systemd_system_unitdir}/${PN}@.service \
25        ${systemd_system_unitdir}/${PN}@.socket \
26        "
27
28# If RMCPP_IFACE is not set by bbappend, set it to default
29DEFAULT_RMCPP_IFACE = "eth0"
30RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
31
32# install parameterized service and socket files
33SYSTEMD_SERVICE_${PN} = " \
34        ${PN}@${RMCPP_IFACE}.service \
35        ${PN}@${RMCPP_IFACE}.socket \
36        "
37
38# To add another RMCPP interface, add similar lines to the
39# following lines in a bbappend:
40#
41# ALT_RMCPP_IFACE = "eth1"
42# SYSTEMD_SERVICE_${PN} += " \
43#     ${PN}@${ALT_RMCPP_IFACE}.service \
44#     ${PN}@${ALT_RMCPP_IFACE}.socket \
45#     "
46
47# Also, be sure to enable a corresponding entry in the channel
48# config file with the same 'name' as the interfaces above
49# Override the default phosphor-ipmi-config.bb with a bbappend
50
51