1SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
5DEPENDS += " \
6        fmt \
7        sdbusplus \
8        sdeventplus \
9        stdplus \
10        systemd \
11        "
12PROVIDES += "virtual/obmc-host-ipmi-hw"
13SRCREV = "314604455606f9baee1e4f5d7fe645d1ebf3c295"
14PV = "1.0+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/kcsbridge.git;branch=master;protocol=https"
18
19SYSTEMD_SERVICE:${PN} = "${PN}@${KCS_DEVICE}.service"
20S = "${WORKDIR}/git"
21
22inherit meson pkgconfig
23inherit systemd
24
25RRECOMMENDS:${PN} += "phosphor-ipmi-host"
26
27RPROVIDES:${PN} += "virtual-obmc-host-ipmi-hw"
28
29FILES:${PN} += "${systemd_system_unitdir}/${PN}@.service"
30
31KCS_DEVICE ?= "ipmi-kcs3"
32