1SUMMARY = "IPMB bridge"
2DESCRIPTION = "The IPMB bridge implements a Dbus compliant interface for \
3implementing IPMB interfaces"
4
5SRC_URI = "git://github.com/openbmc/ipmbbridge.git;branch=master;protocol=https"
6SRCREV = "8227626764edf13350c5f5a5857298a905fb43f7"
7PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
11
12SYSTEMD_SERVICE:${PN} = "ipmb.service"
13
14DEPENDS = "sdbusplus \
15           phosphor-logging \
16           i2c-tools \
17           boost \
18           nlohmann-json"
19
20S = "${WORKDIR}/git"
21inherit cmake pkgconfig systemd
22FILES:${PN} += "/usr/share/ipmbbridge/ipmb-channels.json"
23