1SUMMARY = "Inventory to Sensor config for phosphor-host-ipmi"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4DEPENDS += " \
5           mrw-native \
6           mrw-perl-tools-native \
7           "
8PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
9PR = "r1"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15inherit phosphor-ipmi-host
16inherit mrw-xml
17inherit native
18
19do_install() {
20        DEST=${D}${sensor_datadir}
21        install -d ${DEST}
22        ${bindir}/perl-native/perl \
23            ${bindir}/gen_ipmi_sel.pl \
24            -i ${mrw_datadir}/${MRW_XML} \
25            -m config.yaml \
26            -o ${DEST}/invsensor.yaml
27}
28