1SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
3DEPENDS += " \
4        virtual/phosphor-ipmi-fru-inventory \
5        virtual/phosphor-ipmi-fru-properties \
6        sdbusplus \
7        ${PYTHON_PN}-mako-native \
8        ${PYTHON_PN}-pyyaml-native \
9        phosphor-ipmi-host \
10        phosphor-logging \
11        cli11 \
12        "
13PV = "1.0+git${SRCPV}"
14PR = "r1"
15
16SRC_URI += "file://of-name-to-eeprom.sh"
17
18SYSTEMD_SERVICE:${PN} += "obmc-read-eeprom@.service"
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig
22inherit obmc-phosphor-systemd
23inherit obmc-phosphor-ipmiprovider-symlink
24inherit phosphor-ipmi-fru
25inherit python3native
26
27IPMI_FRU_YAML ?= "${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"
28IPMI_FRU_PROP_YAML ?= "${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml"
29
30
31EXTRA_OEMESON = " \
32        -Dfru_yaml=${IPMI_FRU_YAML} \
33        -Dproperties_yaml=${IPMI_FRU_PROP_YAML} \
34        "
35
36do_install:append() {
37        install -d ${D}${bindir}
38        install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
39}
40
41RDEPENDS:${PN} += "bash"
42
43FILES:${PN} += "${bindir}/of-name-to-eeprom.sh"
44FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
45FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
46FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
47
48require ${BPN}.inc
49
50HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
51