1SUMMARY = "Generate inventory map for phosphor-ipmi-host from a MRW."
2PR = "r1"
3PV = "1.0+git${SRCPV}"
4
5inherit phosphor-ipmi-host
6inherit mrw-xml
7inherit native
8
9require phosphor-ipmi-host.inc
10
11DEPENDS += "mrw-native mrw-perl-tools-native"
12
13DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
14PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
15
16S = "${WORKDIR}/git"
17
18do_install() {
19
20    DEST=${D}${config_datadir}
21    install -d ${DEST}
22
23    ${bindir}/perl-native/perl \
24        ${bindir}/gen_ipmi_fru.pl \
25        -i ${mrw_datadir}/${MRW_XML} \
26        -m ${hostfw_datadir}/config.yaml \
27        -o ${DEST}/config.yaml
28}
29