1SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit phosphor-ipmi-fru
7inherit mrw-xml
8inherit native
9
10SRC_URI += "file://config.yaml"
11
12DEPENDS += " \
13           mrw-native \
14           mrw-perl-tools-native \
15           "
16
17PROVIDES += "virtual/phosphor-ipmi-fru-properties"
18
19S = "${WORKDIR}"
20
21do_install() {
22        DEST=${D}${properties_datadir}
23        install -d ${DEST}
24
25        ${bindir}/perl-native/perl \
26            ${bindir}/gen_fru_properties.pl \
27            -m ${mrw_datadir}/${MRW_XML} \
28            -c config.yaml \
29            -o ${DEST}/extra-properties.yaml
30}
31