1SUMMARY = "To merge the Host and BMC config files generated from MRW "
2DESCRIPTION = "Merge host provided FRU info config file, fru info config, \
3which is not sent by host config, and BMC accessible FRU info config \
4files generated by gen-ipmi-fru.pl into a single config file. \
5fru-gen parser parses the merged config file and generates cpp file"
6PR = "r1"
7
8inherit native
9inherit phosphor-ipmi-host
10inherit obmc-phosphor-license
11
12DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
13DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
14DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
15PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
16
17do_install_append() {
18  SRC=${config_datadir}
19  DEST=${D}${config_datadir}
20  install -d ${DEST}
21  cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
22  cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml
23}
24