1SUMMARY = "To merge the Host and BMC config files generated from MRW "
2DESCRIPTION = "Merge host provided FRU info config file, fru info config, \
3which is not sent by host config, and BMC accessible FRU info config \
4files generated by gen-ipmi-fru.pl into a single config file. \
5fru-gen parser parses the merged config file and generates cpp file"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
9DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
10DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
11PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
12PR = "r1"
13
14inherit phosphor-ipmi-host
15inherit native
16
17do_install:append() {
18  SRC=${config_datadir}
19  DEST=${D}${config_datadir}
20  install -d ${DEST}
21  cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
22  cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml
23}
24