1SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
2PR = "r1"
3PV = "1.0+git${SRCPV}"
4
5inherit phosphor-ipmi-fru
6inherit mrw-xml
7inherit native
8
9require phosphor-ipmi-fru.inc
10
11DEPENDS += "mrw-native mrw-perl-tools-native"
12
13# TODO: remove this dependency after the MRW script
14# has been updated to not require the hostfw metadata.
15DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
16
17PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
18
19S = "${WORKDIR}/git"
20do_install() {
21
22    DEST=${D}${config_datadir}
23    install -d ${DEST}
24
25    ${bindir}/perl-native/perl \
26        ${bindir}/gen_ipmi_fru.pl \
27        -i ${mrw_datadir}/${MRW_XML} \
28        -m ${hostfw_datadir}/config.yaml \
29        -o ${DEST}/config.yaml
30}
31