1SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
2DEPENDS += "mrw-native mrw-perl-tools-native"
3# TODO: remove this dependency after the MRW script
4# has been updated to not require the hostfw metadata.
5DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
6PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
7PV = "1.0+git${SRCPV}"
8PR = "r1"
9
10S = "${WORKDIR}/git"
11
12inherit phosphor-ipmi-fru
13inherit mrw-xml
14inherit native
15
16do_install() {
17    DEST=${D}${config_datadir}
18    install -d ${DEST}
19    ${bindir}/perl-native/perl \
20        ${bindir}/gen_ipmi_fru.pl \
21        -i ${mrw_datadir}/${MRW_XML} \
22        -m ${hostfw_datadir}/config.yaml \
23        -o ${DEST}/config.yaml
24}
25
26require phosphor-ipmi-fru.inc
27