1SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats;branch=master;protocol=https"
17SRCREV = "c8894c55f5d58862f266aebedc43e2652f529a41"
18
19FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
23
24HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"
25
26EXTRA_OECONF += "--disable-tests"
27