1SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += "autoconf-archive-native"
7DEPENDS += "phosphor-ipmi-host"
8SRCREV = "c8894c55f5d58862f266aebedc43e2652f529a41"
9PV = "0.1+git${SRCPV}"
10PR = "r1"
11
12SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats;branch=master;protocol=https"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17inherit obmc-phosphor-ipmiprovider-symlink
18
19EXTRA_OECONF += "--disable-tests"
20
21FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
23FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
24FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"
27