1HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs"
2SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit meson pkgconfig
10
11DEPENDS += " \
12  ipmi-blob-tool \
13  phosphor-ipmi-host \
14  phosphor-logging \
15  "
16
17S = "${WORKDIR}/git"
18SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs;branch=master;protocol=https"
19SRCREV = "83f9992cc60dedb6a2a964a733fd35c89c8a0cfa"
20
21FILES:${PN} += "${libdir}/ipmid-providers"
22
23EXTRA_OEMESON:append = " \
24  -Dtests=disabled \
25  -Dexamples=false \
26  "
27