1SUMMARY = "BMC Generic Binary Blob Store via OEM IPMI Blob Transport"
2DESCRIPTION = "This package provides a read/write/serialize abstraction for storing binary data through IPMI blobs"
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += "phosphor-ipmi-blobs"
7DEPENDS += "phosphor-logging"
8DEPENDS += "nanopb-generator-native"
9DEPENDS += "nanopb-runtime"
10SRCREV = "7e145862d173042a5a7ee7b031a4066192ff77fd"
11PACKAGECONFIG ??= ""
12PACKAGECONFIG[blobtool] = "-Dblobtool=enabled,-Dblobtool=disabled"
13PV = "1.0+git${SRCPV}"
14PR = "r1"
15
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore;branch=master;protocol=https"
17
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig systemd
21
22SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'blobtool', 'binarystore-migration.service', '', d)}"
23
24EXTRA_OEMESON:append = " -Dtests=disabled"
25
26FILES:${PN}:append = " ${libdir}/ipmid-providers"
27FILES:${PN}:append = " ${libdir}/blob-ipmid"
28
29BLOBIPMI_PROVIDER_LIBRARY += "libbinarystore.so"
30