1SUMMARY = "BMC Generic Binary Blob Store via OEM IPMI Blob Transport"
2DESCRIPTION = "This package provides a read/write/serialize abstraction for storing binary data through IPMI blobs"
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += "autoconf-archive-native"
7DEPENDS += "phosphor-ipmi-blobs"
8DEPENDS += "phosphor-logging"
9DEPENDS += "protobuf-native"
10DEPENDS += "protobuf"
11SRCREV = "53992e85d2dc5864db7a7e4a8ee6f6676974e9ba"
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[blobtool] = "-Dblobtool=enabled,-Dblobtool=disabled"
14PV = "1.0+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore;branch=master;protocol=https"
18
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig
22
23EXTRA_OEMESON:append = " -Dtests=disabled"
24
25FILES:${PN}:append = " ${libdir}/ipmid-providers"
26FILES:${PN}:append = " ${libdir}/blob-ipmid"
27
28BLOBIPMI_PROVIDER_LIBRARY += "libbinarystore.so"
29