1SUMMARY = "Phosphor Inventory Manager"
2DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
3lifecycle management application, suitable for use on a wide variety \
4of OpenBMC platforms."
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7
8inherit autotools \
9        pkgconfig \
10        python3native \
11        phosphor-dbus-yaml \
12        phosphor-inventory-manager \
13        obmc-phosphor-dbus-service
14
15require phosphor-inventory-manager.inc
16
17DEPENDS += " \
18        phosphor-inventory-manager-assettag \
19        phosphor-dbus-interfaces \
20        phosphor-logging \
21        sdbusplus \
22        ${PYTHON_PN}-sdbus++-native \
23        autoconf-archive-native \
24        libcereal \
25        ${PYTHON_PN}-native \
26        ${PYTHON_PN}-pyyaml-native \
27        ${PYTHON_PN}-mako-native \
28        "
29
30OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
31OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
32
33DBUS_SERVICE:${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
34
35S = "${WORKDIR}/git"
36
37EXTRA_OECONF = " \
38        YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
39        BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
40        INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
41        IFACE=${OBMC_INVENTORY_MGR_IFACE} \
42        IFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
43        "
44
45PACKAGECONFIG ??= ""
46PACKAGECONFIG[associations] = "--enable-associations, --disable-associations,nlohmann-json,"
47