1SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesystem mount reference implementation."
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6PR = "r1"
7
8inherit allarch
9
10RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
11
12S = "${WORKDIR}"
13SRC_URI += "file://obmc-init.sh"
14SRC_URI += "file://obmc-shutdown.sh"
15SRC_URI += "file://obmc-update.sh"
16SRC_URI += "file://whitelist"
17
18do_install() {
19	for f in init-download-url init-options
20	do
21		if test -e $f
22		then
23			install -m 0755 ${WORKDIR}/$f ${D}/$f
24		fi
25	done
26        install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
27        install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
28        install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
29        install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
30        install -d ${D}/dev
31        mknod -m 622 ${D}/dev/console c 5 1
32}
33
34FILES:${PN} += " /init /shutdown /update /whitelist /dev "
35FILES:${PN} += " /init-options /init-download-url "
36