1DESCRIPTION = "Small image capable of booting a device. The kernel includes \
2the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
3first 'init' program more efficiently."
4
5# Init scripts
6INIT_PACKAGE = "obmc-phosphor-initfs"
7INIT_PACKAGE_df-phosphor-mmc = "phosphor-mmc-init"
8
9PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
10
11# Do not pollute the initrd image with rootfs features
12IMAGE_FEATURES = "read-only-rootfs"
13
14export IMAGE_BASENAME = "obmc-phosphor-initramfs"
15IMAGE_LINGUAS = ""
16
17LICENSE = "MIT"
18
19IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
20inherit core-image
21
22IMAGE_ROOTFS_SIZE = "8192"
23IMAGE_ROOTFS_EXTRA_SPACE = "0"
24
25# Needed for the set_user_group functions to succeed
26DEPENDS += "shadow-native"
27
28PACKAGE_INSTALL_remove = "shadow"
29PACKAGE_EXCLUDE = "shadow"
30BAD_RECOMMENDATIONS += "busybox-syslog"
31