1DESCRIPTION = "Small image capable of booting a device. The kernel includes \
2the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
3first 'init' program more efficiently."
4LICENSE = "MIT"
5# Needed for the set_user_group functions to succeed
6DEPENDS += "shadow-native"
7
8inherit core-image
9
10export IMAGE_BASENAME = "obmc-phosphor-initramfs"
11
12BAD_RECOMMENDATIONS += "busybox-syslog"
13
14PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
15PACKAGE_INSTALL:remove = "shadow"
16
17# Init scripts
18INIT_PACKAGE = "obmc-phosphor-initfs"
19INIT_PACKAGE:df-phosphor-mmc = "phosphor-mmc-init"
20# Do not pollute the initrd image with rootfs features
21IMAGE_FEATURES = "read-only-rootfs"
22IMAGE_LINGUAS = ""
23IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
24IMAGE_ROOTFS_SIZE = "8192"
25IMAGE_ROOTFS_EXTRA_SPACE = "0"
26PACKAGE_EXCLUDE = "shadow"
27