1DESCRIPTION = "Image with Phosphor, a software stack for hardware management \
2in devices with baseboard management controllers.  The image supports the \
3full OpenBMC feature set for devices of all types."
4
5IMAGE_LINGUAS = ""
6
7IMAGE_FEATURES += " \
8        obmc-bmc-state-mgmt \
9        obmc-bmcweb \
10        obmc-chassis-mgmt \
11        obmc-chassis-state-mgmt \
12        obmc-console \
13        obmc-dbus-monitor \
14        obmc-devtools \
15        obmc-fan-control \
16        obmc-fan-mgmt \
17        obmc-flash-mgmt \
18        obmc-fru-ipmi \
19        obmc-health-monitor \
20        obmc-host-ctl \
21        obmc-host-ipmi \
22        obmc-host-state-mgmt \
23        obmc-ikvm \
24        obmc-inventory \
25        obmc-leds \
26        obmc-logging-mgmt \
27        obmc-remote-logging-mgmt \
28        obmc-rng \
29        obmc-net-ipmi \
30        obmc-sensors \
31        obmc-software \
32        obmc-system-mgmt \
33        obmc-user-mgmt \
34        obmc-user-mgmt-ldap \
35        ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'read-only-rootfs', '', d)} \
36        ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', 'read-only-rootfs', '', d)} \
37        ssh-server-dropbear \
38        obmc-debug-collector \
39        obmc-network-mgmt \
40        obmc-settings-mgmt \
41        obmc-telemetry \
42        "
43
44LICENSE = "Apache-2.0"
45
46inherit obmc-phosphor-image
47
48# The /etc/version file is misleading and not useful.  Remove it.
49# Users should instead rely on /etc/os-release.
50ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
51
52# The shadow recipe provides the binaries(like useradd, usermod) needed by the
53# phosphor-user-manager.
54ROOTFS_RO_UNNEEDED_remove = "shadow"
55