1DESCRIPTION = "Image with Phosphor, a software stack for hardware management \
2in devices with baseboard management controllers.  The image supports the \
3full OpenBMC feature set for devices of all types."
4LICENSE = "Apache-2.0"
5
6inherit obmc-phosphor-image
7
8# The /etc/version file is misleading and not useful.  Remove it.
9# Users should instead rely on /etc/os-release.
10ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
11
12IMAGE_LINGUAS = ""
13IMAGE_FEATURES += " \
14        obmc-bmc-state-mgmt \
15        obmc-bmcweb \
16        obmc-chassis-mgmt \
17        obmc-chassis-state-mgmt \
18        obmc-console \
19        obmc-devtools \
20        obmc-fan-control \
21        obmc-fan-mgmt \
22        obmc-flash-mgmt \
23        obmc-fru-ipmi \
24        obmc-health-monitor \
25        obmc-host-ctl \
26        obmc-host-ipmi \
27        obmc-host-state-mgmt \
28        obmc-ikvm \
29        obmc-inventory \
30        obmc-leds \
31        obmc-logging-mgmt \
32        obmc-remote-logging-mgmt \
33        obmc-rng \
34        obmc-net-ipmi \
35        obmc-sensors \
36        obmc-software \
37        obmc-system-mgmt \
38        obmc-user-mgmt \
39        obmc-user-mgmt-ldap \
40        ${@bb.utils.contains_any('DISTRO_FEATURES', \
41            'obmc-ubi-fs phosphor-mmc obmc-static-norootfs', \
42            'read-only-rootfs overlayfs-etc', '', d)} \
43        ssh-server-dropbear \
44        obmc-debug-collector \
45        obmc-network-mgmt \
46        obmc-settings-mgmt \
47        obmc-telemetry \
48        obmc-dmtf-pmci \
49        "
50# The shadow recipe provides the binaries(like useradd, usermod) needed by the
51# phosphor-user-manager.
52ROOTFS_RO_UNNEEDED:remove = "shadow"
53
54# We need to set overlayfs-etc so that the dropbear/openssh keys don't end up
55# in a volatile file system, but we always have our own init that sets these
56# up.  Add enough bogus values here that rootfs-postcommands.bbclass does what
57# we want without overlayfs-etc.bbclass messing things up.
58OVERLAYFS_ETC_USE_ORIG_INIT_NAME="0"
59OVERLAYFS_ETC_MOUNT_POINT = "/this/is/unused"
60OVERLAYFS_ETC_FSTYPE = "not_a_fs_type"
61OVERLAYFS_ETC_DEVICE = "/dev/null"
62python create_overlayfs_etc_preinit:append() {
63    os.unlink(preinitPath)
64}
65