1SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
3HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += "sdbusplus"
7DEPENDS += "sdeventplus"
8DEPENDS += "phosphor-dbus-interfaces"
9DEPENDS += "systemd"
10DEPENDS += "libgpiod"
11SRCREV = "0ea7357e6cc44c0340314165d4f50de0de48a6a6"
12PACKAGECONFIG ?= ""
13PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
14PV = "0.1+git${SRCPV}"
15PR = "r1"
16
17SRC_URI = "git://github.com/openbmc/phosphor-host-postd;branch=master;protocol=https"
18
19S = "${WORKDIR}/git"
20SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
21SERVICE_FILE = "lpcsnoop.service"
22SYSTEMD_PACKAGES = "${PN}"
23SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
24SERVICE_FILE_7SEG = " \
25  postcode-7seg@.service \
26  postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
27"
28SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"
29
30inherit meson
31inherit pkgconfig
32inherit systemd
33
34EXTRA_OEMESON:append = " \
35    -Dsnoop-device=${SNOOP_DEVICE} \
36    -Dpost-code-bytes=${POST_CODE_BYTES} \
37    -Dtests=disabled \
38"
39
40POST_CODE_BYTES ?= "1"
417SEG_GPIO ?= "0"
42POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
43