1SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
3HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit meson
10inherit pkgconfig
11inherit systemd
12
13PACKAGECONFIG ?= ""
14PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
15
16DEPENDS += "sdbusplus"
17DEPENDS += "sdeventplus"
18DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "systemd"
20
21S = "${WORKDIR}/git"
22SRC_URI = "git://github.com/openbmc/phosphor-host-postd"
23SRCREV = "ba5258f7158e8a0e61043290aff0873358509158"
24
25SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
26POST_CODE_BYTES ?= "1"
27
28SERVICE_FILE = "lpcsnoop.service"
29SYSTEMD_PACKAGES = "${PN}"
30SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
31
32EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
33EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
34EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
35
36POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
37SERVICE_FILE_7SEG = " \
38  postcode-7seg@.service \
39  postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
40"
41SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"
42