1SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
3HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit meson
10inherit pkgconfig
11inherit systemd
12
13PACKAGECONFIG ?= ""
14PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
15
16DEPENDS += "sdbusplus"
17DEPENDS += "sdeventplus"
18DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "systemd"
20DEPENDS += "libgpiod"
21
22S = "${WORKDIR}/git"
23SRC_URI = "git://github.com/openbmc/phosphor-host-postd;branch=master;protocol=https"
24SRCREV = "18119acc04b45556efda4b2ce6d964da6561d3ab"
25
26SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
27POST_CODE_BYTES ?= "1"
287SEG_GPIO ?= "0"
29
30SERVICE_FILE = "lpcsnoop.service"
31SYSTEMD_PACKAGES = "${PN}"
32SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
33
34EXTRA_OEMESON:append = " \
35    -Dsnoop-device=${SNOOP_DEVICE} \
36    -Dpost-code-bytes=${POST_CODE_BYTES} \
37    -Dtests=disabled \
38"
39
40POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
41SERVICE_FILE_7SEG = " \
42  postcode-7seg@.service \
43  postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
44"
45SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"
46