1SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
6DEPENDS += "sdbusplus"
7DEPENDS += "phosphor-dbus-interfaces"
8DEPENDS += "sdeventplus"
9DEPENDS += "phosphor-logging"
10DEPENDS += "nlohmann-json"
11SRCREV = "a3c17d0fcd101a698e24e20237b59bd84249eb3f"
12PV = "0.1+git${SRCPV}"
13PR = "r1"
14
15SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https;branch=master"
16
17S = "${WORKDIR}/git"
18SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"
19
20inherit meson pkgconfig
21inherit systemd
22
23do_install:append() {
24  if [ -e "${WORKDIR}/bmc_health_config.json" ]; then
25    install -d ${D}${sysconfdir}/healthMon
26    install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}${sysconfdir}/healthMon
27  fi
28}
29