1SUMMARY = "Insecure private key for testing and development"
2DESCRIPTION = "Do not use this key to sign images."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8inherit native
9
10SRC_URI += "file://OpenBMC.priv"
11
12do_install() {
13	bbplain "Using an insecure image signing key!"
14	install -d ${D}${datadir}
15	install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir}
16}
17