1SUMMARY = "Provides a host firmware image"
2DESCRIPTION = "Use a bbappend to add the image files"
3PR = "r1"
4
5inherit allarch
6inherit deploy
7
8HOSTFW_LICENSE ?= "Apache-2.0"
9HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
10
11LICENSE = "${HOSTFW_LICENSE}"
12LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
13
14do_compile() {
15    # The image directory can be used as the source to create a filesystem to
16    # add to the BMC image.
17    install -d ${B}/image
18
19    # Install an image-hostfw file in the update directory to be included in
20    # the code update tarball.
21    install -d ${B}/update
22}
23
24do_deploy() {
25    install -d ${DEPLOYDIR}/hostfw/image
26    install -d ${DEPLOYDIR}/hostfw/update
27    cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/
28    cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/
29}
30
31addtask deploy before do_build after do_compile
32