1SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
3HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10
11inherit phosphor-pid-control
12inherit obmc-phosphor-ipmiprovider-symlink
13inherit systemd
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
17SRCREV = "304c0332f884866a2b846b907050ebb2dda9b145"
18
19# Each platform will need a service file that starts
20# at an appropriate time per system.  For instance, if
21# your system relies on passive dbus for fans or other
22# sensors then it may be prudent to wait for all of them.
23
24DEPENDS += "autoconf-archive-native"
25DEPENDS += "sdbusplus"
26DEPENDS += "phosphor-dbus-interfaces"
27DEPENDS += "phosphor-logging"
28DEPENDS += "libevdev"
29DEPENDS += "nlohmann-json"
30DEPENDS += "cli11"
31DEPENDS += "boost"
32
33# We depend on this to be built first so we can build our providers.
34DEPENDS += "phosphor-ipmi-host"
35
36SERVICE_FILE = "phosphor-pid-control.service"
37SYSTEMD_PACKAGES = "${PN}"
38SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
39
40EXTRA_OECONF = " \
41  SYSTEMD_TARGET="multi-user.target" \
42       "
43
44FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
45
46# The following installs the OEM IPMI handler for the fan controls.
47FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
48FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
49FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
50FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
51
52HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"
53