10e04b2e9SBrad Bishop# Provides the config file for the phosphor-fan-presence application.
20e04b2e9SBrad Bishop# The default config file is empty.  To provide a real one,
30e04b2e9SBrad Bishop# append this recipe in a layer, add:
412fc939cSPatrick Williams# FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
50e04b2e9SBrad Bishop# and provide a config file.
60e04b2e9SBrad BishopSUMMARY = "Config file for phosphor-fan-presence"
70e04b2e9SBrad BishopLICENSE = "Apache-2.0"
86f3f0aa7SBrad BishopLIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
9*9936f86dSEd TanousPROVIDES += "virtual/phosphor-fan-presence-config"
10*9936f86dSEd TanousPR = "r1"
11*9936f86dSEd Tanous
12*9936f86dSEd TanousSRC_URI = "file://config.yaml"
13*9936f86dSEd Tanous
14*9936f86dSEd TanousS = "${WORKDIR}"
150e04b2e9SBrad Bishop
160e04b2e9SBrad Bishopinherit allarch
170e04b2e9SBrad Bishopinherit phosphor-fan
180e04b2e9SBrad Bishop
190e04b2e9SBrad Bishopdo_install() {
200e04b2e9SBrad Bishop        install -D config.yaml ${D}${presence_datadir}/config.yaml
210e04b2e9SBrad Bishop}
220e04b2e9SBrad Bishop
2312fc939cSPatrick WilliamsFILES:${PN} += "${presence_datadir}/config.yaml"
24