1*0e04b2e9SBrad BishopSUMMARY = "Generate fan control YAML from the MRW"
2*0e04b2e9SBrad BishopPR = "r1"
3*0e04b2e9SBrad BishopLICENSE = "Apache-2.0"
4*0e04b2e9SBrad Bishop
5*0e04b2e9SBrad Bishopinherit allarch
6*0e04b2e9SBrad Bishopinherit phosphor-fan
7*0e04b2e9SBrad Bishopinherit mrw-xml
8*0e04b2e9SBrad Bishop
9*0e04b2e9SBrad BishopS = "${WORKDIR}"
10*0e04b2e9SBrad BishopDEPENDS = "mrw-native mrw-perl-tools-native"
11*0e04b2e9SBrad BishopPROVIDES += "virtual/phosphor-fan-control-fan-config"
12*0e04b2e9SBrad Bishop
13*0e04b2e9SBrad Bishopdo_compile() {
14*0e04b2e9SBrad Bishop    ${bindir}/perl-native/perl \
15*0e04b2e9SBrad Bishop        ${bindir}/gen_fan_zone_yaml.pl \
16*0e04b2e9SBrad Bishop        -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
17*0e04b2e9SBrad Bishop        -o fans.yaml
18*0e04b2e9SBrad Bishop}
19*0e04b2e9SBrad Bishop
20*0e04b2e9SBrad Bishopdo_install() {
21*0e04b2e9SBrad Bishop        install -D fans.yaml ${D}${control_datadir}/fans.yaml
22*0e04b2e9SBrad Bishop}
23*0e04b2e9SBrad Bishop
24*0e04b2e9SBrad BishopFILES_${PN} += "${control_datadir}/fans.yaml"
25