10e04b2e9SBrad BishopSUMMARY = "Generate fan control YAML from the MRW"
20e04b2e9SBrad BishopLICENSE = "Apache-2.0"
3*9936f86dSEd TanousDEPENDS = "mrw-native mrw-perl-tools-native"
4*9936f86dSEd TanousPROVIDES += "virtual/phosphor-fan-control-fan-config"
5*9936f86dSEd TanousPR = "r1"
6*9936f86dSEd Tanous
7*9936f86dSEd TanousS = "${WORKDIR}"
80e04b2e9SBrad Bishop
90e04b2e9SBrad Bishopinherit allarch
100e04b2e9SBrad Bishopinherit phosphor-fan
110e04b2e9SBrad Bishopinherit mrw-xml
120e04b2e9SBrad Bishop
130e04b2e9SBrad Bishopdo_compile() {
140e04b2e9SBrad Bishop    ${bindir}/perl-native/perl \
150e04b2e9SBrad Bishop        ${bindir}/gen_fan_zone_yaml.pl \
160e04b2e9SBrad Bishop        -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
170e04b2e9SBrad Bishop        -o fans.yaml
180e04b2e9SBrad Bishop}
190e04b2e9SBrad Bishopdo_install() {
200e04b2e9SBrad Bishop        install -D fans.yaml ${D}${control_datadir}/fans.yaml
210e04b2e9SBrad Bishop}
220e04b2e9SBrad Bishop
2312fc939cSPatrick WilliamsFILES:${PN} += "${control_datadir}/fans.yaml"
24