1SUMMARY = "Debug trigger"
2DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
3HOMEPAGE = "https://github.com/openbmc/debug-trigger"
4
5SRC_URI = "git://github.com/openbmc/debug-trigger;branch=master;protocol=https"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10S = "${WORKDIR}/git"
11
12inherit meson
13inherit pkgconfig
14inherit systemd
15
16PR = "r1"
17PV = "0.1+git${SRCPV}"
18SRCREV = "1161642d2288f71549f0c9f89d09807ca251b58f"
19
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
21
22DEBUG_TRIGGERS ?= ""
23
24PACKAGECONFIG[systemd] = " \
25    -Dsystemd=true, \
26    -Dsystemd=false, \
27    systemd"
28
29PACKAGECONFIG[triggers] = " \
30    -Dtriggers=${DEBUG_TRIGGERS}, \
31    -Dtriggers=[], \
32    systemd udev"
33
34SYSTEMD_SERVICE:${PN} += "debug-trigger@.service"
35