1SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor;branch=master;protocol=https"
10SRCREV = "74dc24adab6e83cc3058efc458dd5698933b87b5"
11
12inherit autotools \
13        pkgconfig \
14        python3native \
15        phosphor-dbus-monitor \
16        obmc-phosphor-systemd
17
18PACKAGE_BEFORE_PN = "phosphor-msl-verify"
19SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
20SYSTEMD_SERVICE:phosphor-msl-verify = "phosphor-msl-verify.service"
21
22DEPENDS += " \
23        ${PN}-config \
24        phosphor-logging \
25        autoconf-archive-native \
26        ${PYTHON_PN}-sdbus++-native \
27        sdeventplus \
28        gtest \
29        phosphor-snmp \
30        ${PYTHON_PN}-native \
31        ${PYTHON_PN}-pyyaml-native \
32        ${PYTHON_PN}-setuptools-native \
33        ${PYTHON_PN}-mako-native \
34        "
35
36FILES:phosphor-msl-verify = "${bindir}/phosphor-msl-verify"
37
38S = "${WORKDIR}/git"
39
40EXTRA_OECONF = " \
41        YAML_PATH=${STAGING_DIR_HOST}${config_dir} \
42        "
43