1SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5S = "${WORKDIR}/git"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
10inherit python3native
11inherit phosphor-dbus-yaml
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "${PYTHON_PN}-sdbus++-native"
15
16SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
17SRCREV = "0f5729187d1e271453dc80433ab92814f9fb6393"
18
19PACKAGECONFIG ??= "libphosphor_dbus"
20PACKAGECONFIG[libphosphor_dbus] = " \
21        --enable-libphosphor_dbus, \
22        --disable-libphosphor_dbus, \
23        systemd sdbusplus, \
24        libsystemd \
25        "
26
27PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
28PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
29
30BBCLASSEXTEND += "native nativesdk"
31