1SUMMARY = "Phosphor Time Manager daemon"
2DESCRIPTION = "Daemon to cater to BMC and HOST time management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6DEPENDS += "systemd"
7DEPENDS += "sdbusplus"
8DEPENDS += "${PYTHON_PN}-sdbus++-native"
9DEPENDS += "phosphor-logging"
10DEPENDS += "phosphor-dbus-interfaces"
11SRCREV = "53abd0dce13ea014d5ea9a9cc6280774e5a9e543"
12PV = "1.0+git${SRCPV}"
13PR = "r1"
14
15SRC_URI = "git://github.com/openbmc/phosphor-time-manager;branch=master;protocol=https"
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig python3native
20inherit obmc-phosphor-dbus-service
21
22EXTRA_OEMESON = " -Dtests=disabled"
23
24RDEPENDS:${PN} += "phosphor-settings-manager"
25RDEPENDS:${PN} += "phosphor-network"
26RDEPENDS:${PN} += "phosphor-objmgr"
27
28DBUS_SERVICE:${PN} += "xyz.openbmc_project.Time.Manager.service"
29