1SUMMARY = "Phosphor Time Manager daemon"
2DESCRIPTION = "Daemon to cater to BMC and HOST time management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig python3native
9inherit obmc-phosphor-dbus-service
10
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "phosphor-mapper"
13DEPENDS += "systemd"
14DEPENDS += "sdbusplus"
15DEPENDS += "${PYTHON_PN}-sdbus++-native"
16DEPENDS += "phosphor-logging"
17DEPENDS += "phosphor-dbus-interfaces"
18RDEPENDS_${PN} += "phosphor-settings-manager"
19RDEPENDS_${PN} += "phosphor-network"
20RDEPENDS_${PN} += "phosphor-mapper"
21
22SRC_URI += "git://github.com/openbmc/phosphor-time-manager"
23SRCREV = "248a709c83e80f81a687c971b79ff292c4778fb0"
24PV = "1.0+git${SRCPV}"
25S = "${WORKDIR}/git"
26
27DBUS_SERVICE_${PN} += "xyz.openbmc_project.Time.Manager.service"
28