1SUMMARY = "Enables reboots on host failures"
2DESCRIPTION = "Manages the settings entry that controls reboots \
3on host failures"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6PR = "r1"
7
8SYSTEMD_SERVICE:${PN} += "${TMPL}"
9SYSTEMD_LINK:${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_HOST_INSTANCES')}"
10SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES"
11
12inherit obmc-phosphor-systemd
13
14TMPL = "host-failure-reboots@.service"
15INSTFMT = "host-failure-reboots@{0}.service"
16LINK_FMT = "${TMPL}:${INSTFMT}"
17