1SUMMARY = "Phosphor Certificate Manager"
2DESCRIPTION = "Manages client and server certificates"
3HOMEPAGE = "https://github.com/openbmc/phosphor-certificate-manager"
4
5PR = "r1"
6PV = "0.1+git${SRCPV}"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI = "git://github.com/openbmc/phosphor-certificate-manager"
12SRCREV = "5c515c21fb8d3c2f983ccdadca859b0f2cb282cf"
13
14inherit autotools \
15        pkgconfig \
16        obmc-phosphor-systemd
17
18DEPENDS = " \
19        autoconf-archive-native \
20        openssl \
21        phosphor-dbus-interfaces \
22        phosphor-logging \
23        sdbusplus \
24        sdeventplus \
25        "
26
27S = "${WORKDIR}/git"
28
29CERT_TMPL = "phosphor-certificate-manager@.service"
30SYSTEMD_SERVICE_${PN} = "${CERT_TMPL}"
31