1SUMMARY = "Common C++ functions"
2DESCRIPTION = "Common C++ functions."
3HOMEPAGE = "http://github.com/openbmc/stdplus"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += " \
7  function2 \
8  fmt \
9  liburing \
10  "
11SRCREV = "7aa2a42be328438726a2aff665d649444a1a54d4"
12PV = "0.1+git${SRCPV}"
13PR = "r1"
14
15SRC_URI = "git://github.com/openbmc/stdplus;branch=master;protocol=https"
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig
20
21EXTRA_OEMESON = " \
22        -Dexamples=false \
23        -Dtests=disabled \
24        -Dgtest=disabled \
25        "
26
27PACKAGES =+ "libstdplus libstdplus-dl libstdplus-io_uring"
28
29FILES:libstdplus = "${libdir}/libstdplus.so.*"
30FILES:libstdplus-dl = "${libdir}/libstdplus-dl.so.*"
31FILES:libstdplus-io_uring = "${libdir}/libstdplus-io_uring.so.*"
32