1SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3
4inherit meson
5inherit python3native
6include sdbusplus-rev.inc
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
11S = "${WORKDIR}/git"
12
13DEPENDS += " \
14        ${PYTHON_PN}-inflection-native \
15        ${PYTHON_PN}-mako-native \
16        ${PYTHON_PN}-pyyaml-native \
17        boost \
18        systemd \
19        "
20
21EXTRA_OEMESON:append = " \
22        -Dtests=disabled \
23        -Dexamples=disabled \
24        "
25