1DESCRIPTION = "Command line tools for hardware device registers"
2HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
6SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https"
7PV = "v1.6+git${SRCPV}"
8
9inherit obmc-phosphor-systemd
10
11S = "${WORKDIR}/git"
12FILES_${PN} = "${sbindir}"
13
14do_compile() {
15    # CC is overridden in the Makefile, so override it harder in the invocation
16    oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
17}
18
19# The "install" make target runs the binary to create links for subcommands.
20# The links are excessive and this doesn't work for cross compiling.
21do_install() {
22    install -d ${D}${sbindir}
23    install -m 0755 iotools ${D}${sbindir}
24}
25
26SYSTEMD_SERVICE_${PN} += "iotools-setup.service"
27