1# WARNING!
2#
3# These modifications to os-release disable the bitbake parse
4# cache (for the os-release recipe only).  Before copying
5# and pasting into another recipe ensure it is understood
6# what that means!
7
8def run_git(d, cmd):
9    try:
10        oeroot = d.getVar('COREBASE', True)
11        return bb.process.run(("export PSEUDO_DISABLED=1; " +
12                               "git --work-tree %s --git-dir %s/.git %s")
13            % (oeroot, oeroot, cmd))[0].strip('\n')
14    except Exception as e:
15        bb.warn("Unexpected exception from 'git' call: %s" % e)
16        pass
17
18# DISTRO_VERSION can be overridden by a bbappend or config, so it must be a
19# weak override.  But, when a variable is weakly overridden the definition
20# and not the contents are used in the task-hash (for sstate reuse).  We need
21# a strong variable in the vardeps chain for do_compile so that we get the
22# contents of the 'git describe --dirty' call.  Create a strong/immediate
23# indirection via PHOSPHOR_OS_RELEASE_DISTRO_VERSION.
24PHOSPHOR_OS_RELEASE_DISTRO_VERSION := "${@run_git(d, 'describe --dirty')}"
25DISTRO_VERSION ??= "${PHOSPHOR_OS_RELEASE_DISTRO_VERSION}"
26
27VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
28
29BUILD_ID := "${@run_git(d, 'describe --abbrev=0')}"
30OPENBMC_TARGET_MACHINE = "${MACHINE}"
31
32OS_RELEASE_FIELDS:append = " BUILD_ID OPENBMC_TARGET_MACHINE EXTENDED_VERSION"
33
34# Ensure the git commands run every time bitbake is invoked.
35BB_DONT_CACHE = "1"
36
37# Make os-release available to other recipes.
38SYSROOT_DIRS:append = " ${sysconfdir}"
39