1SUMMARY = "Network Block Device Proxy"
2HOMEPAGE = "https://github.com/openbmc/jsnbd"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8inherit autotools pkgconfig
9
10DEPENDS += "json-c"
11DEPENDS += "udev"
12
13RDEPENDS_${PN} += "nbd-client"
14
15S = "${WORKDIR}/git"
16
17SRC_URI = "git://github.com/openbmc/jsnbd"
18SRCREV = "74c8a728212021e750686f4ec797e5f16283168a"
19
20NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
21
22do_install_append() {
23    install -d ${D}${sysconfdir}/nbd-proxy/
24    install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
25}
26