1SUMMARY = "Parser for OpenPOWER-format FRU VPD"
2DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit autotools pkgconfig
7inherit openpower-fru-vpd
8inherit pythonnative
9inherit obmc-phosphor-systemd
10
11require ${PN}.inc
12
13SRC_URI += "file://70-op-vpd.rules"
14
15DEPENDS += " \
16        virtual/openpower-fru-vpd-layout \
17        virtual/openpower-fru-inventory \
18        virtual/openpower-fru-properties \
19        sdbusplus \
20        phosphor-logging \
21        python-mako-native \
22        python-pyyaml-native \
23        autoconf-archive-native \
24        "
25
26RDEPENDS_${PN} += " \
27               sdbusplus \
28               phosphor-logging \
29               "
30
31SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
32
33S = "${WORKDIR}/git"
34
35EXTRA_OECONF = " \
36             FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
37             PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
38             "
39
40do_install_append() {
41        SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
42        DEST=${D}${inventory_envdir}
43        install -d ${DEST}
44        install ${SRC}/inventory ${DEST}
45
46        install -d ${D}/${base_libdir}/udev/rules.d/
47        install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/
48}
49